USER’S

MANUAL

CPR Electronic Mannequin Assistant

Engineering Health Solutions

May, 2009
## Revision Sheet

<table>
<thead>
<tr>
<th>Release No.</th>
<th>Date</th>
<th>Revision Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rev. 1</td>
<td>5/03/00</td>
<td>User’s Manual Template and Checklist (draft for end of phase 3)</td>
</tr>
</tbody>
</table>
I have carefully assessed the User’s Manual for the CPR eTAM. This document has been completed in accordance with the requirements of the ICOM5047 course.

MANAGEMENT CERTIFICATION -

______ The document is accepted.

__X___ The document is accepted pending the changes noted.

______ The document is not accepted.

We fully accept the changes as needed improvements and authorize initiation of work to proceed.

__ Jomar Rosario ________________  _______________________________
NAME  DATE  Project Leader

__ Edvier Cabassa & Juan Gorritz ___ ________________  _______________________________
NAME  DATE  Software Department

__ Arelis Perez & José Lombay ______  _______________________________
NAME  DATE  Hardware Department

__ Frank Mendoza ____________________  _______________________________
NAME  DATE  Client

__ Silicon Labs ____________________  _______________________________
NAME  DATE  Sponsor
# USER'S MANUAL

## TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page #</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0 GENERAL INFORMATION</td>
<td>1-1</td>
</tr>
<tr>
<td>1.1 System Overview</td>
<td>1-1</td>
</tr>
<tr>
<td>1.2 Project References</td>
<td>1-2</td>
</tr>
<tr>
<td>1.3 Authorized Use Permission</td>
<td>1-2</td>
</tr>
<tr>
<td>1.4 Points of Contact</td>
<td>1-2</td>
</tr>
<tr>
<td>1.4.1 Information</td>
<td>1-2</td>
</tr>
<tr>
<td>1.4.2 Help Desk</td>
<td>1-2</td>
</tr>
<tr>
<td>1.5 Organization of the Manual</td>
<td>1-3</td>
</tr>
<tr>
<td>1.6 Acronyms and Abbreviations</td>
<td>1-3</td>
</tr>
<tr>
<td>2.0 SYSTEM SUMMARY</td>
<td>2-1</td>
</tr>
<tr>
<td>2.1 System Configuration</td>
<td>2-1</td>
</tr>
<tr>
<td>2.2 Data Flows</td>
<td>2-5</td>
</tr>
<tr>
<td>2.3 User Access Levels</td>
<td>2-8</td>
</tr>
<tr>
<td>2.4 Contingencies and Alternate Modes of Operation</td>
<td>2-8</td>
</tr>
<tr>
<td>3.0 GETTING STARTED</td>
<td>3-1</td>
</tr>
<tr>
<td>3.1 Logging On</td>
<td>3-1</td>
</tr>
<tr>
<td>3.2 System Menu</td>
<td>3-1</td>
</tr>
<tr>
<td>3.2.8 Test USB data transfer</td>
<td>3-6</td>
</tr>
<tr>
<td>3.2.9 Tutorials</td>
<td>3-7</td>
</tr>
<tr>
<td>3.2.10 Training</td>
<td>3-12</td>
</tr>
<tr>
<td>3.3 Changing Password</td>
<td>3-14</td>
</tr>
<tr>
<td>3.4 Exit System</td>
<td>3-14</td>
</tr>
<tr>
<td>4.0 REPORTing</td>
<td>4-1</td>
</tr>
<tr>
<td>4.1 Report Capabilities</td>
<td>4-1</td>
</tr>
</tbody>
</table>
1.0 GENERAL INFORMATION
1.0 GENERAL INFORMATION

1.1 System Overview

Cardiopulmonary resuscitation (CPR) is a procedure used with unconscious victims of some type of trauma which has caused the heart to stop beating in order to simulate a functional heartbeat and oxygen intake through breathing. Currently, CPR training is usually performed using a mannequin and supervised by an instructor. We improve the quality of the training process to perform CPR creating a tool to facilitate the job of the instructors by electronically monitoring students practicing CPR on a training mannequin. Our product consist of a mannequin that will be monitored using different sensors and a software application which retrieve and process the information in order to provide proper training and support the instructor. The mannequin simulates a person who needs CPR and responds to the steps if they were applied according to the rules of the CPR manual or instructor. The trainer use software installed in a normal computer to control the mannequin’s actions and obtain results of his or her students in real time, with the ability to save the data or retrieve previous session data from a database.
1.2 Project References


1.3 Authorized Use Permission

Only the people that acquired the system through our company and agree with the following terms are authorized to utilize it:

“This product in no way, shape, or form intends on replacing conventional, professional teaching of CPR procedures. Its only intention is the facilitation of teaching and evaluating CPR students. Proper use of the product does not imply that the user will be certified to give CPR.

It falls under the responsibility of the instructor to take into consideration the legal aspects concerning CPR instruction and performing CPR.”

1.4 Points of Contact

1.4.1 Information

Engineering Health Solutions is a group that intends to bring solutions to problems that involves the health and safety. We spec to solve issues that can do the difference in the life of many people.

1.4.2 Help Desk

For emergency assistance please contact EHS by this email: engineering.health.solutions@gmail.com.
1.5 Organization of the Manual

Provide a list of the major sections of the User’s Manual (1.0, 2.0, 3.0, etc.) and a brief description of what is contained in each section.

1.6 Acronyms and Abbreviations

- CPR eTAM – CPR Electronic Teaching Assistant Mannequin
- EHS – Engineering Health Solutions
- CPR eTAM app - CPR eTAM software
2.0 SYSTEM SUMMARY
2.0 SYSTEM SUMMARY

CPReTAM is a mannequin monitored and controlled by sensors, a microprocessor, and computer software in a personal computer to simulate the steps performed in a CPR rescue session. This tool facilitates the job of the instructors by electronically monitoring students practicing CPR on a training mannequin. We provide the hardware and software to identify when a student is not following the correct procedure; monitoring chest compressions, the victims breathing and pulse, and the position of the victim's head using specialized software to configure the mannequin and display the data provided from the real time situation in the mannequin.

The CPR eTAM app can be divided into three principal modules: How To, Training and Setting. Between all those modules, it allows the user to create an account, manage student information, run training sessions to evaluate and train students, and store results of those sessions. The user is able to change the evaluation metrics used in the program to evaluate the student at the training session.

In order for the system to perform everything mentioned above, you need to have a 120VAC wall plug, 4xAA batteries, and a computer with a usb port connector.

2.1 System Configuration

Briefly describe and depict graphically the equipment, communications, and networks used by the system. Include the type of computer input and output devices.

You need to assemble some parts of the system before use it. Here are pictures of the steps that show you how to mount the system.

(1) Put the head of the mannequin in the torso
(2) Support the head in the torso with the lock.

(3) Connect the cable of the head in the port of the torso.
(4) Turn around the mannequin and connect the cable of the blue box in the blue port.
(5) Connect the green cable of the head to the green port.

(6) Connect the blue box to a switch.
2.0 System Summary

(7) Turn on the blue box.

2.2 Data Flows
The system can be divided into two main modules, hardware and software. The hardware module has a one-way communication from the sensor and devices to the micro-controller. At the software module exists two way communications between the Graphical User Interfaces class, the Main class, user and the database. The communication in the software module indicates the interaction between the user and the application. The user could be inputting student information on the system, and when the user is done, the system will provide a feedback form to the user, indicating the status of the request of the user. There is a two-way communication between both modules. This design was implemented for the hardware module to send information about the sensors to the application, while the application indicates the micro-controller when a training session is started and when a training session ended.
2.3  User Access Levels

The system currently allows two types of users: unlogged and logged users. The unlogged user have access to the “How to”, “Training”, and “Settings” of the application, while the logged user has access to those and is able to add/delete student, course, and section information and to store training session results.

2.4  Contingencies and Alternate Modes of Operation

The system has been developed to detect and correct some errors. At the hardware module, if a connection is disconnected at the sensors, the status Light Emitting Diode (green) on the bottom of the mannequin will turn off. If there is a problem with the micro-controller power, the Light Emitting Diode (red) at the box. At the software module, we are utilizing “try-catch statements” which ensure the continuity of the application. If an instruction fails, the statements shows a window indicating an error message that will allow the developers to find and correct the error displayed.
3.0 GETTING STARTED
3.0 GETTING STARTED

This section provides a general flow walkthrough of the system from initiation through the exit.

3.1 Logging On

To logging on the system you must double click the CPReTAM application. When you are in the principal frame, click file and then log on into the system.

3.2 System Menu

This section describes the system menu first encountered by the user, as well as the navigation paths to functions noted on the screen.
3.0 Getting Started

3.2.1 View my account info

Log on ➔ File ➔ Account ➔ View my account info

![AccountInfo window]

**AccountInfo**

- **Full name:** [Enter name]
- **Username:** [Enter username]
- **New Password:** [Enter new password]
- **Confirm password:** [Confirm new password]
- **Secret question:** [Enter secret question]
- **Answer:** [Enter answer]

[Buttons: Apply, Delete account, Cancel]

3.2.2 Create a course

Log on ➔ File ➔ Account ➔ Create a course

![Create a course window]

**Tutorials:** Interactive steps for effectively using this program.

**Add course**

- **Course code:** [Enter code]
- **Course number:** [Enter number]
- **Course section:** [Enter section]
- **Section capacity:** [Enter capacity]

[Buttons: Ok, Cancel]

**Settings:** Configure this program to your liking.

[More Info]
3.2.3 Add a section to a course

Log on ➔ File ➔ Account ➔ Add a section to a course

3.2.4 Add students

Log on ➔ File ➔ Account ➔ Add students
3.2.5 Delete course

Log on → File → Account → Delete course

3.2.6 Delete students

Log on → File → Account → Delete students
3.2.7 Delete sections

Log on  File  Account  Delete sections

![Diagram of the Delete section process]

Tutorials: Interactive steps for effectively using this program.

More Info

Settings: Configure this program to your liking.

Logged on: Yes

Exit
3.2.8 Test USB data transfer

Log on ➔ Back button ➔ Edit ➔ Test USB

Tutorials: Interactive steps for effectively using this program.

Settings: Configure this program to your liking.

More Info

Logged on: Yes
3.2.9 Tutorials

Select Tutorial Icon (First icon at main screen).

- **Perform CPR: The steps necessary to successfully performing the CPR procedure**
  - More Info

- **Add course/students: Learn how to add a course and students into the system**
  - Less Info

- **View past results: Create a report to follow student progress**
  - More Info
3.2.9.1 How to Perform CPR

Tutorial→Perform CPR (first icon at tutorial screen)

Welcome to the tutorial for performing CPR.

DISCLAIMER: Before we get started, please keep in mind that this tutorial does not intend to replace formal CPR training. Completing this tutorial does not mean that you are certified to perform this procedure, but will help in obtaining a certification. In the probable case that you are a CPR instructor, the purpose of this tutorial is to see how the program will determine whether or not a student is performing the steps correctly.

Images courtesy of the Association of First Aiders (AoFA). For more information please visit www.AoFA.org.

To continue on to the next part of the tutorial, click Next. If you need to go back for some reason, click Back. If at any time you wish to quit the tutorial and return to the main page, click Quit. Now that we have that out of the way, let’s begin!
Welcome to the tutorial for performing CPR.

DISCLAIMER Before we get started, please keep in mind that this tutorial does not intend to replace formal CPR training. Completing this tutorial does not mean that you are certified to perform this procedure, but will help in obtaining a certification. In the probable case that you are a CPR instructor, the purpose of this tutorial is to see how the program will determine whether or not a student is performing the steps correctly.

Images courtesy of the Association of First Aiders (AoFA). For more information please visit www.AoFA.org

To continue on to the next part of the tutorial you need to go back for some reason, click the time you wish to quit the tutorial and return to click Quit. Now that we have that out of the way...

What is interactive mode?

Quit Previous Next

Interactive mode: Off
3.2.9.2 How to Add Courses

Tutorial ⇒ Add Courses/Students (second icon at tutorial screen).

To log in, simply click the File menu strip item, and select Log in. A new window will pop up, asking for your username and password. Enter them into the appropriate field, and select Ok. If you entered the information correctly, the program goes back to the main window, and the status strip should read "Logged on: Yes".
3.2.9.3 View past results tutorial.

Tutorial → View Past Results (third icon at tutorial screen).
3.2.10 Training

If you are logon you can see the information described below.

3.2.10.1 View/edit course

Training→View/Edit courses (One icon at training screen).
3.2.10.2 Begin a training session
Training → Begin a training session (second icon at training screen).
3.2.11 Settings

Select Settings (Third icon at main screen).

3.3 Changing Password

To change the password you must press the logon button and click the *Forgot your password?* option and enter your username. In the next frame you must answer your secret question, enter a new password, and confirm it. Now your password is change.

3.4 Exit System

To exit the system you must find out the way to see the exit red X pressing back or quit button. It depends on the frame you are.
4.0 REPORTING
4.0 REPORTING

4.1 Report Capabilities

The application is able to create a report of the session realized by a student. The report starts with a table that shows the last 5 grades of the student within a section of a course. That table also shows the average grade of the student. If you select a student, by clicking over his/her name, you can see the passing grade expected by the evaluator, the grade obtained by the student and where the student failed.

Table summary:

<table>
<thead>
<tr>
<th>Student name</th>
<th>Student number</th>
<th>Session grades</th>
<th>Avg</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Juanma Feliciano</td>
<td>802-03-1061</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magic Johnson</td>
<td>555-55-5555</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Frank Sinatra</td>
<td>569-22-3265</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Jerry Seinfeld</td>
<td>456-03-4568</td>
<td>79 100 96 100 20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>George Costanza</td>
<td>456-40-5879</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elaine Benes</td>
<td>123-45-6789</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cosmo Kramer</td>
<td>987-85-4321</td>
<td>N/A N/A N/A N/A N/A</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Click on a student’s name to jump to his or her detailed report.

No procedures performed yet!
Results:

<table>
<thead>
<tr>
<th>Session number</th>
<th>2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grade</td>
<td>32/100</td>
</tr>
<tr>
<td>Passing grade for this session</td>
<td>80/100</td>
</tr>
</tbody>
</table>

First cycle
- Consciousness check ✔
- Head-tilt, chin-lift ✗
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✗
- Pulse check ✗
- Chest compressions ✗
- Head-tilt, chin-lift ✗
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✗

Second cycle
- Head-tilt, chin-lift ✗
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✗
- Chest compressions ✗
- Head-tilt, chin-lift ✔
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✔

Third cycle
- Head-tilt, chin-lift ✗
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✔
- Chest compressions ✗
- Head-tilt, chin-lift ✔
- Nose pinch ✗
- First rescue breath ✔
- Second rescue breath ✔